$re = '/^((((End|end|Start|start)?\s)?#[1-9][0-9]* @([1-9][0-9]*(h|m?))+\s(.|\n|\r)+)|(Merge.+branch \'.+\'(.+into.+)?))/';
$str = '#2603 @1m sous modules
^((((End|end|Start|start)?\\s)?#[1-9][0-9]* @([1-9][0-9]*(h|m?))+\\s(.|\\n|\\r)+)|(Merge.+branch \'.+\'(.+into.+)?))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);