const regex = /^((((End|end|Start|start)?\s)?#[1-9][0-9]* @([1-9][0-9]*(h|m?))+\s(.|\n|\r)+)|(Merge.+branch '.+'(.+into.+)?))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((((End|end|Start|start)?\\s)?#[1-9][0-9]* @([1-9][0-9]*(h|m?))+\\s(.|\\n|\\r)+)|(Merge.+branch \'.+\'(.+into.+)?))', 'g')
const str = `#2603 @1m sous modules
^((((End|end|Start|start)?\\s)?#[1-9][0-9]* @([1-9][0-9]*(h|m?))+\\s(.|\\n|\\r)+)|(Merge.+branch '.+'(.+into.+)?))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}