re = /^[\p{L}]+(?:\s[\p{L}]+)*$/m
str = 'GEÇERLİ
ÖMER
ENES SEFA
ENES SEFA KÜCCÜK
ŞEYDA
İÇçiöşŞğĞ
GEÇERSİZ
1enes se
.dsds
enes dsdsd
öçds12
dd2sds'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end