#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\p{L}]+(?:\s[\p{L}]+)*$"
Local $sString = "GEÇERLİ" & @CRLF & _
"ÖMER" & @CRLF & _
"ENES SEFA" & @CRLF & _
"ENES SEFA KÜCCÜK" & @CRLF & _
"ŞEYDA" & @CRLF & _
"İÇçiöşŞğĞ" & @CRLF & _
"" & @CRLF & _
"GEÇERSİZ" & @CRLF & _
"1enes se" & @CRLF & _
".dsds " & @CRLF & _
"enes dsdsd" & @CRLF & _
"öçds12" & @CRLF & _
"dd2sds"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")