$re = '/\s*comb\s*:\s*process\s*\((.*?)\)/m';
$str = ' comb : process (i_desc_mngr, r)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);