package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*comb\s*:\s*process\s*\((.*?)\)`)
var str = ` comb : process (i_desc_mngr, r)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}