import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\d]*?(\\+?\\d\\d)?(?:[^\\d]*?0)?(?:[^\\d]*?([1-9]))((?:[^\\d]*?\\d\\d){4})$";
final String string = "0674420606\n"
+ "06 74 42 06 06\n"
+ "06/74/42/06/06\n"
+ "06-74-42-06-06\n"
+ "06.74.42.06.06\n"
+ "+33674420606\n"
+ "+330674420606\n"
+ "+33 6 74 42 06 06\n"
+ "(+33)674420606\n"
+ "(+33) 674420606\n"
+ "+33 0674420606\n\n"
+ "// ^[^\\d]*?(\\+?\\d\\d)?(?:[^\\d]*?0)?(?:[^\\d]*?([1-9]))((?:[^\\d]*?\\d\\d){4})$\n\n"
+ "// [^\\d+]\n"
+ "// ^[^\\d]?(\\+?\\d\\d)?0?([1-9])((?:\\d\\d){4})$\n"
+ "// ^\\+?\\+?\\d\\d?0?[1-9](?:\\d\\d){4}$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}