#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\d]*?(\+?\d\d)?(?:[^\d]*?0)?(?:[^\d]*?([1-9]))((?:[^\d]*?\d\d){4})$"
Local $sString = "0674420606" & @CRLF & _
"06 74 42 06 06" & @CRLF & _
"06/74/42/06/06" & @CRLF & _
"06-74-42-06-06" & @CRLF & _
"06.74.42.06.06" & @CRLF & _
"+33674420606" & @CRLF & _
"+330674420606" & @CRLF & _
"+33 6 74 42 06 06" & @CRLF & _
"(+33)674420606" & @CRLF & _
"(+33) 674420606" & @CRLF & _
"+33 0674420606" & @CRLF & _
"" & @CRLF & _
"// ^[^\d]*?(\+?\d\d)?(?:[^\d]*?0)?(?:[^\d]*?([1-9]))((?:[^\d]*?\d\d){4})$" & @CRLF & _
"" & @CRLF & _
"// [^\d+]" & @CRLF & _
"// ^[^\d]?(\+?\d\d)?0?([1-9])((?:\d\d){4})$" & @CRLF & _
"// ^\+?\+?\d\d?0?[1-9](?:\d\d){4}$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")