# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/value="(?=<\?php)[^"]+"//g;t' <<< "<html>
<h1>I poop <?php echo $whatHePoops; ?></h1>
</html>
<input type=\"text\" class=\"input input-1\" id=\"CompanyName\" name=\"CompanyName\" data-toggle=\"tooltip\" data-placement=\"top\" title=\"Company Name/ Name of the Customer\" placeholder=\"Company Name/ Name of the Customer\" value=\"<?php echo $root['companyProfile']['customerCompanyName']; ?>\">"