use strict;
my $str = 'Your Amazon.com order has shipped (#114-7286434-0549003)
Fwd: Your Amazon.com order of "Diva Ring Light Nebula 18..." has shipped!
Your Amazon.com order has shipped (#114-7286434-0549003)
Your Amazon.com order has shipped
Fwd: Your sdjcns order has deleted
Fwd: Your amazon order is cancelled
Your Amazon.in order (#171-8110001-7994703) of "Prestige Electric Kettle..." has been dispatched!
Your Amazon.in order #171-8110001-7994703 has been delivered
Your Amazon.in order #171-8110001-7994703 is out for delivery
Your Amazon.in order #171-8110001-7994703 has been shipped
Fwd: Your Amazon.com order of "Diva Ring Light Nebula 18..." has shipped!';
my $regex = qr/(?:\b(?:your|amazon\.com|shipped)\b.*){3}/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}