package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:\b(?:your|amazon\.com|shipped)\b.*){3}`)
var str = `Your Amazon.com order has shipped (#114-7286434-0549003)
Fwd: Your Amazon.com order of "Diva Ring Light Nebula 18..." has shipped!
Your Amazon.com order has shipped (#114-7286434-0549003)
Your Amazon.com order has shipped
Fwd: Your sdjcns order has deleted
Fwd: Your amazon order is cancelled
Your Amazon.in order (#171-8110001-7994703) of "Prestige Electric Kettle..." has been dispatched!
Your Amazon.in order #171-8110001-7994703 has been delivered
Your Amazon.in order #171-8110001-7994703 is out for delivery
Your Amazon.in order #171-8110001-7994703 has been shipped
Fwd: Your Amazon.com order of "Diva Ring Light Nebula 18..." has shipped!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}