re = /^P(\d+([,\.]\d+)?Y)?(\d+([,\.]\d+)?M)?(\d+([,\.]\d+)?D)?(T(\d+([,\.]\d+)?H)?(\d+([,\.]\d+)?M)?(\d+([,\.]\d+)?S)?)?$/m
str = 'P1Y
PT35M
P0.5Y
P4W'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end