import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^P(\\d+([,\\.]\\d+)?Y)?(\\d+([,\\.]\\d+)?M)?(\\d+([,\\.]\\d+)?D)?(T(\\d+([,\\.]\\d+)?H)?(\\d+([,\\.]\\d+)?M)?(\\d+([,\\.]\\d+)?S)?)?$";
final String string = "P1Y\n"
+ "PT35M\n"
+ "P0.5Y\n"
+ "P4W";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}