re = /(?s:.*\n)\K(?:G70|F70|G71|F71).*(\d{5}).*(?:IMPORTO|Prelievo).*(?=(?:G70|G71|F70|F71)\s\d{4}\s\d{5}\s\d{2}\/\d{2}\/\d{4}\s11:11)/
str = 'G70 1234 00012
....
....
....
....
IMPORTO
....
....
F70 1234 00013
....
....
Prelievo
....
....
F70 1234 00014 10/10/2019 11:11
....'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end