import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s:.*\\n)\\K(?:G70|F70|G71|F71).*(\\d{5}).*(?:IMPORTO|Prelievo).*(?=(?:G70|G71|F70|F71)\\s\\d{4}\\s\\d{5}\\s\\d{2}\\/\\d{2}\\/\\d{4}\\s11:11)";
final String string = "G70 1234 00012\n"
+ "....\n"
+ "....\n"
+ "....\n"
+ "....\n"
+ "IMPORTO\n"
+ "....\n"
+ "....\n"
+ "F70 1234 00013\n"
+ "....\n"
+ "....\n"
+ "Prelievo\n"
+ "....\n"
+ "....\n"
+ "F70 1234 00014 10/10/2019 11:11\n"
+ "....";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}