# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<(?<tagName>\w+)(([^<]*\/>)|(.*?\/(\k<tagName>)>))"
test_str = " <child name = \"child_name1\" type = \"child_type1\"> <subchild id = \"1\" auth=\"auth1\">Value1</subchild> </child> <child name = \"child_name2\" type = \"child_type2\"> <subchild id = \"2\" auth=\"auth1\">Value2</subchild> <subchild id = \"3\" auth=\"auth2\">Value3</subchild> <subchild id = \"4\" auth=\"auth3\"></subchild> <subchild id = \"5\" auth=\"auth3\"/> </child>"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.