using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?<tagName>\w+)(([^<]*\/>)|(.*?\/(\k<tagName>)>))";
string input = @" <child name = ""child_name1"" type = ""child_type1""> <subchild id = ""1"" auth=""auth1"">Value1</subchild> </child> <child name = ""child_name2"" type = ""child_type2""> <subchild id = ""2"" auth=""auth1"">Value2</subchild> <subchild id = ""3"" auth=""auth2"">Value3</subchild> <subchild id = ""4"" auth=""auth3""></subchild> <subchild id = ""5"" auth=""auth3""/> </child>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}