use strict;
my $str = 'Aceite de oliva virgen extra CARBONELL, garrafa 3 litros
Aceite de oliva virgen CARBONELL, botella 1 litro
First Bike, bici sin pedales roja,edad rec:2-5 años CHICCO, peso máximo 25 Kg
Bombón de almendras MAGNUM, 3+1 uds., caja 423 g
Bote PLAY-DOH,pasta de moldear, sutidos sorpresa, edad rec:+2 años, pack 4uds
Magdalena 0% azúcar LA BELLA EASO, 8 unid., paquete 232 g
Magdalena 0% azúcar LA BELLA EASO, 8 unid., paquete 232 g
Cerveza MAHOU 5 Estrellas, pack botellín 12x25 cl
Bote PLAY-DOH,pasta de moldear, sutidos sorpresa, edad rec:+2 años, pack 4uds';
my $regex = qr/(\d+?[\+x])?\d+ ?(litros?|u(ni)?ds?|kg|g|cl)(.?, \w+ \d+ ?(litros?|u(ni)?ds|kg|g))?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}