const regex = /(\d+?[\+x])?\d+ ?(litros?|u(ni)?ds?|kg|g|cl)(.?, \w+ \d+ ?(litros?|u(ni)?ds|kg|g))?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+?[\\+x])?\\d+ ?(litros?|u(ni)?ds?|kg|g|cl)(.?, \\w+ \\d+ ?(litros?|u(ni)?ds|kg|g))?', 'gmi')
const str = `Aceite de oliva virgen extra CARBONELL, garrafa 3 litros
Aceite de oliva virgen CARBONELL, botella 1 litro
First Bike, bici sin pedales roja,edad rec:2-5 años CHICCO, peso máximo 25 Kg
Bombón de almendras MAGNUM, 3+1 uds., caja 423 g
Bote PLAY-DOH,pasta de moldear, sutidos sorpresa, edad rec:+2 años, pack 4uds
Magdalena 0% azúcar LA BELLA EASO, 8 unid., paquete 232 g
Magdalena 0% azúcar LA BELLA EASO, 8 unid., paquete 232 g
Cerveza MAHOU 5 Estrellas, pack botellín 12x25 cl
Bote PLAY-DOH,pasta de moldear, sutidos sorpresa, edad rec:+2 años, pack 4uds`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}