re = /^((?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[\^$*.[\]{}()?\-"!@#%&\/\,><':;|_~`+=]).{7,})\S$/m
str = 'Passwo1@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end