$re = '/^((?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[\^$*.[\]{}()?\-"!@#%&\/\,><\':;|_~`+=]).{7,})\S$/m';
$str = 'Passwo1@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);