re = /([a-zA-Z]+[" "])?{{ ((\d+)\.(\w+))+ }}((([" "])[a-zA-Z]+)?)+
/m
str = '{{ 0.output }}
select {{ 0.OUTPUT }} from testsdsasd adsdas
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end