$re = '/([a-zA-Z]+[" "])?{{ ((\d+)\.(\w+))+ }}((([" "])[a-zA-Z]+)?)+
/m';
$str = '{{ 0.output }}
select {{ 0.OUTPUT }} from testsdsasd adsdas
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);