#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-\s\[\s\]\s*(?<duedate>\/\/[\d\.]+)(?<rest>.*)"
Local $sString = "- [ ] //2.7.2022 @rk @tt +inline +utilities mal was machen ohne Return und blablabla" & @CRLF & _
"aber das nichtmehr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")