$re = '/-\s\[\s\]\s*(?<duedate>\/\/[\d\.]+)(?<rest>.*)/m';
$str = '- [ ] //2.7.2022 @rk @tt +inline +utilities mal was machen ohne Return und blablabla
aber das nichtmehr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);