$re = '/^(\/)?index\.php\?path\=en(\/)?(.*)?/';
$str = '/index.php?path=en';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);