package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\/)?index\.php\?path\=en(\/)?(.*)?`)
var str = `/index.php?path=en`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}