$re = '/(?:^\[FOR\](\w+)=(\d+).(\d+))|(?:\[NEXT\]((?1)))/';
$str = '[FOR]FUNCO=1,99
Id funzionario per esempio #ID_FCCOD#
[NEXT]FUNCO
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);