const regex = /(?:^\[FOR\](\w+)=(\d+).(\d+))|(?:\[NEXT\]((?1)))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^\\[FOR\\](\\w+)=(\\d+).(\\d+))|(?:\\[NEXT\\]((?1)))', 'g')
const str = `[FOR]FUNCO=1,99
Id funzionario per esempio #ID_FCCOD#
[NEXT]FUNCO
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}