$re = '/\w.*solarwinds.orion\\\\(solarwinds.*|swjobengine.*|netflowservice.*|counterfetcher.*)\.exe$/m';
$str = '// Explanation
// Matches all files part of the "orion" folder that start with solarwinds,swjobengine,netflowservice,counterfetcher and ends with ".exe"
// Some Solarwinds exe starting with "solarwinds."
e:\\program files\\solarwinds\\orion\\solarwinds.orion.logmgmt.syslogservice.exe
e:\\program files\\solarwinds\\orion\\solarwinds.businesslayerhostx64.exe
e:\\program files\\solarwinds\\orion\\solarwinds.orion.logmgmt.syslogservice.exe
e:\\program files\\solarwinds\\orion\\solarwinds.collector.service.exe
e:\\program files\\solarwinds\\orion\\solarwinds.orion.logmgmt.pollingservice.exe
e:\\program files\\solarwinds\\orion\\solarwinds.businesslayerhost.exe
e:\\program files\\solarwinds\\orion\\solarwinds.orion.logmgmt.trapservice.exe
e:\\program files\\solarwinds\\orion\\solarwinds.recommendations.service.exe
e:\\program files\\solarwinds\\orion\\solarwinds.informationservice.servicev3.exe
e:\\program files\\solarwinds\\orion\\solarwinds.highavailability.service.exe
e:\\program files\\solarwinds\\orion\\solarwinds.servicehost.process.exe
e:\\program files\\solarwinds\\orion\\solarwinds.topology.calculator.exe
// Example with another drive
C:\\program files\\solarwinds\\orion\\solarwinds.topology.calculator.exe
// Some Solarwinds exe NOT starting with "solarwinds."
e:\\program files\\solarwinds\\orion\\netflowservice.exe
e:\\program files\\solarwinds\\orion\\swjobengineworker2.exe
e:\\program files\\solarwinds\\orion\\swjobenginesvc2.exe
e:\\program files\\solarwinds\\orion\\swjobengineworker2x64.exe
e:\\program files\\solarwinds\\orion\\counterfetcher.exe
// Non Orion folders
c:\\program files\\common files\\solarwinds\\administrationservice\\solarwinds.administration.exe
// TESTS
e:\\program files\\solarwinds\\orion\\solarwinds.exe
e:\\program files\\solarwinds\\orion\\solarwinds.test.exe
e:\\program files\\solarwinds\\orion\\solarwinds.test.test2.exe
Without orion folder
e:\\program files\\solarwinds\\NotOrion\\solarwinds.servicehost.process.exe
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);