#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w.*solarwinds.orion\\(solarwinds.*|swjobengine.*|netflowservice.*|counterfetcher.*)\.exe$"
Local $sString = "// Explanation" & @CRLF & _
"// Matches all files part of the "orion" folder that start with solarwinds,swjobengine,netflowservice,counterfetcher and ends with ".exe"" & @CRLF & _
"" & @CRLF & _
"// Some Solarwinds exe starting with "solarwinds."" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.orion.logmgmt.syslogservice.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.businesslayerhostx64.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.orion.logmgmt.syslogservice.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.collector.service.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.orion.logmgmt.pollingservice.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.businesslayerhost.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.orion.logmgmt.trapservice.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.recommendations.service.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.informationservice.servicev3.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.highavailability.service.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.servicehost.process.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.topology.calculator.exe" & @CRLF & _
"" & @CRLF & _
"// Example with another drive" & @CRLF & _
"C:\program files\solarwinds\orion\solarwinds.topology.calculator.exe" & @CRLF & _
"" & @CRLF & _
"// Some Solarwinds exe NOT starting with "solarwinds."" & @CRLF & _
"e:\program files\solarwinds\orion\netflowservice.exe" & @CRLF & _
"e:\program files\solarwinds\orion\swjobengineworker2.exe" & @CRLF & _
"e:\program files\solarwinds\orion\swjobenginesvc2.exe" & @CRLF & _
"e:\program files\solarwinds\orion\swjobengineworker2x64.exe" & @CRLF & _
"e:\program files\solarwinds\orion\counterfetcher.exe" & @CRLF & _
"" & @CRLF & _
"// Non Orion folders" & @CRLF & _
"c:\program files\common files\solarwinds\administrationservice\solarwinds.administration.exe" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"// TESTS" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.test.exe" & @CRLF & _
"e:\program files\solarwinds\orion\solarwinds.test.test2.exe" & @CRLF & _
"" & @CRLF & _
"Without orion folder" & @CRLF & _
"e:\program files\solarwinds\NotOrion\solarwinds.servicehost.process.exe" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")