import Foundation
let pattern = #"^[A-Z]{2}[0-9A-Z]{2,32}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"CZ6508000000192000145999"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}