const regex = /^[A-Z]{2}[0-9A-Z]{2,32}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]{2}[0-9A-Z]{2,32}$', '')
const str = `CZ6508000000192000145999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}