$re = '/\W+/';
$str = 'A quick brown fox jumps over the lazy dog.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);