package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\W+`)
var str = `A quick brown fox jumps over the lazy dog.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}