$re = '/^:\x1B\[./m';
$str = 'big command result
...
...
...
...
here
:[K';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);