$re = '/(\d+\.?\d+)/m';
$str = '₹1200.09 and €3294.54 , ₹223450';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);