package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+\.?\d+)`)
var str = `₹1200.09 and €3294.54 , ₹223450`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}