re = /^(?<hostip>[^ ]+) - - \[(?<timestamp>[^ ]+\s-\d+)\] "(?<method>[^ ]+)\s(?<request>[^ ]+) HTTP\/\d\.\d"\s(?<response>\d+)\s(?<size>\d+)$/m
str = '162.115.219.252 - - [18/Jun/2015:13:00:04 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:14 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:20 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:24 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:34 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:39 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:44 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:54 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:00 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:04 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:09 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:14 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:24 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:34 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:39 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:44 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:54 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:04 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:09 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:14 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:20 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:24 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:34 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:44 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:49 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:54 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:59 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:04 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:09 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:14 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:24 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:34 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:44 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:49 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:54 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:04 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:09 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:14 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:19 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:24 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:34 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:39 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:44 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:54 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:05:04 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end