use strict;
my $str = '162.115.219.252 - - [18/Jun/2015:13:00:04 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:14 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:20 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:24 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:34 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:39 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:44 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:00:54 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:00 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:04 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:09 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:14 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:24 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:34 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:39 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:44 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:01:54 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:04 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:09 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:14 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:20 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:24 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:34 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:44 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:49 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:54 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:02:59 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:04 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:09 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:14 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:24 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:34 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:44 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:49 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:03:54 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:04 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:09 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:14 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:19 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:24 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:34 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:39 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:44 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:04:54 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
162.115.219.252 - - [18/Jun/2015:13:05:04 -0700] "HEAD /myv/status.jsp HTTP/1.1" 200 0
';
my $regex = qr/^(?<hostip>[^ ]+) - - \[(?<timestamp>[^ ]+\s-\d+)\] "(?<method>[^ ]+)\s(?<request>[^ ]+) HTTP\/\d\.\d"\s(?<response>\d+)\s(?<size>\d+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}