$re = '/([0-9]*\.?[0-9]*\*x\^[0-2])/i';
$str = '4*X^0+4*X^1-9.3*X^2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);