package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([0-9]*\.?[0-9]*\*x\^[0-2])`)
var str = `4*X^0+4*X^1-9.3*X^2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}