# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a.*<\/a>"
test_str = ("<dl>\n"
"<dd>[1] <a href=\"/wiki/Geb%C3%A4ude\" title=\"Gebäude\">Gebäude</a>, <a href=\"/wiki/R%C3%A4umlichkeit\" title=\"Räumlichkeit\">Räumlichkeit</a>, <a href=\"/wiki/Unterkunft\" title=\"Unterkunft\">Unterkunft</a>\n"
"</dd>\n"
"<dd>[2] die <a href=\"/wiki/Gemeinschaft\" title=\"Gemeinschaft\">Gemeinschaft</a> der <a href=\"/wiki/Mensch\" title=\"Mensch\">Menschen</a>, die unter einem Dach zusammen leben, wohnen oder arbeiten</dd>\n"
"<dd>[3] der <a href=\"/wiki/Unterhaltung\" title=\"Unterhaltung\">Unterhaltung</a> dienendes Gebäude</dd>\n"
"<dd>[4] <i><a href=\"/wiki/Astrologie\" title=\"Astrologie\">Astrologie</a>:</i> <a href=\"/wiki/Tierkreiszeichen\" title=\"Tierkreiszeichen\">Tierkreiszeichen</a>\n"
"</dd>\n"
"<dd>[5] <a href=\"/w/index.php?title=Herrscherhaus&action=edit&redlink=1\" class=\"new\" title=\"Herrscherhaus (Seite nicht vorhanden)\">Herrscherhaus</a>\n"
"</dd>\n"
"<dd>[6] <a href=\"/wiki/Firma\" title=\"Firma\">Firma</a>, <a href=\"/wiki/Unternehmen\" title=\"Unternehmen\">Unternehmen</a>\n"
"</dd>\n"
"<dd>[7] <a href=\"/wiki/scherzhaft\" title=\"scherzhaft\"><i>scherzhaft</i></a> <a href=\"/wiki/Freund\" title=\"Freund\">Freund</a>\n"
"</dd>\n"
"<dd>[8] <i><a href=\"/wiki/umgangssprachlich\" title=\"umgangssprachlich\">umgangssprachlich</a>:</i> Gehäuse der <a href=\"/wiki/Schnecke\" title=\"Schnecke\">Schnecke</a>\n"
"</dd>\n"
"<dd>[9] Gasthaus oder <a href=\"/wiki/Gastst%C3%A4tte\" title=\"Gaststätte\">Gaststätte</a>\n"
"</dd>\n"
"</dl>\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.