const regex = /<a.*<\/a>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.*<\\\/a>', '')
const str = `<dl>
<dd>[1] <a href="/wiki/Geb%C3%A4ude" title="Gebäude">Gebäude</a>, <a href="/wiki/R%C3%A4umlichkeit" title="Räumlichkeit">Räumlichkeit</a>, <a href="/wiki/Unterkunft" title="Unterkunft">Unterkunft</a>
</dd>
<dd>[2] die <a href="/wiki/Gemeinschaft" title="Gemeinschaft">Gemeinschaft</a> der <a href="/wiki/Mensch" title="Mensch">Menschen</a>, die unter einem Dach zusammen leben, wohnen oder arbeiten</dd>
<dd>[3] der <a href="/wiki/Unterhaltung" title="Unterhaltung">Unterhaltung</a> dienendes Gebäude</dd>
<dd>[4] <i><a href="/wiki/Astrologie" title="Astrologie">Astrologie</a>:</i> <a href="/wiki/Tierkreiszeichen" title="Tierkreiszeichen">Tierkreiszeichen</a>
</dd>
<dd>[5] <a href="/w/index.php?title=Herrscherhaus&action=edit&redlink=1" class="new" title="Herrscherhaus (Seite nicht vorhanden)">Herrscherhaus</a>
</dd>
<dd>[6] <a href="/wiki/Firma" title="Firma">Firma</a>, <a href="/wiki/Unternehmen" title="Unternehmen">Unternehmen</a>
</dd>
<dd>[7] <a href="/wiki/scherzhaft" title="scherzhaft"><i>scherzhaft</i></a> <a href="/wiki/Freund" title="Freund">Freund</a>
</dd>
<dd>[8] <i><a href="/wiki/umgangssprachlich" title="umgangssprachlich">umgangssprachlich</a>:</i> Gehäuse der <a href="/wiki/Schnecke" title="Schnecke">Schnecke</a>
</dd>
<dd>[9] Gasthaus oder <a href="/wiki/Gastst%C3%A4tte" title="Gaststätte">Gaststätte</a>
</dd>
</dl>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}