$re = '/([0-9])[\sx]+([0-9,.]+)/m';
$str = 'foobar 5x10kg
foobar 5 x 10kg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);