package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9])[\sx]+([0-9,.]+)`)
var str = `foobar 5x10kg
foobar 5 x 10kg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}