$re = '/(FST|(?<!SCO)RAP((?!\s?POS)|(?=AT+N)))/m';
$str = 'RAPPOS
RAP POS
SCORAP
FSTLA1
RAPATN
RAP ATTN
RAP001
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);