const regex = /(FST|(?<!SCO)RAP((?!\s?POS)|(?=AT+N)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(FST|(?<!SCO)RAP((?!\\s?POS)|(?=AT+N)))', 'gm')
const str = `RAPPOS
RAP POS
SCORAP
FSTLA1
RAPATN
RAP ATTN
RAP001
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}