re = /^<iframe.+?src="https?:\/\/www\.youtube\.com\/embed\/([a-zA-Z0-9_-]{11})"[^>]+?><\/iframe>$/
str = '<iframe width="560" height="315" src="https://www.youtube.com/embed/wRqjJ7SENDI" frameborder="0" allowfullscreen></iframe>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end