$re = '/^<iframe.+?src="https?:\/\/www\.youtube\.com\/embed\/([a-zA-Z0-9_-]{11})"[^>]+?><\/iframe>$/';
$str = '<iframe width="560" height="315" src="https://www.youtube.com/embed/wRqjJ7SENDI" frameborder="0" allowfullscreen></iframe>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);